Lumagen Forum
Lumagen Support Forum: Official Lumagen Video Processor & Scaler Forum

Members   Search      Help    Register    Login    Home
Home » Lumagen Video Processors & Scalers » Radiance XD User Support » RadianceXD issue
RadianceXD issue Sun, 20 November 2016 16:26 Go to next message
MarkAV is currently offline MarkAV
Messages: 3
Registered: June 2013
Location: Midwest
Junior Member
I'm running into a problem. My XD has been running great for years. It did have a problem with the power supply, but I replaced that and it was back up and happy for a few months.

Now, I have two issues - possibly related.

1) When I turn on the XD, it goes from Red to Green to Both lights black (off). I don't seem to be able to do anything in this mode. Also, there is no signal on the TV, so it's hard to tell what is going on.

2) If I powercycle the source that was the last input(at least the one time I tried it), I can see an image on the TV, but it is strangely zoomed. I tried all the aspect ratio controls and I looked at the diagnostics information and nothing seems to be out of whack (it's sending 1920x1080@60 to a 1920x1080 TV). It's pretty easy to get back to problem 1 from here, so I haven't been able to diagnose it more fully.

In addition, my control system (RS-232 based) does not seem to be happy talking to it (nothing works), so I'm purely using the remote. That may be completely unrelated, but I thought I would mention it).

My firmware is pretty ancient, so that may be a good first place to start. Thoughts?

Thanks,
Mark
Re: RadianceXD issue Tue, 22 November 2016 17:28 Go to previous messageGo to next message
Gordon, Convergent-AV is currently offline Gordon, Convergent-AV
Messages: 1643
Registered: October 2004
Location: UK
Lumagen Expert
Convergent AV
Doesn't sound too good...Update the firmware to latest spec to start always. Then unplug all sources and power it up and see if you can sync with the tv to see OSD of scaler. If you do then try one source at a time....if not let us know


Distributor of Lumagen products in EU
WWW.CONVERGENT-AV.CO.UK
Re: RadianceXD issue Wed, 01 February 2017 16:08 Go to previous messageGo to next message
MarkAV is currently offline MarkAV
Messages: 3
Registered: June 2013
Location: Midwest
Junior Member
Looks like the power supply again. It's doing the green/red dance.
Re: RadianceXD issue Sat, 17 February 2018 19:21 Go to previous messageGo to next message
MarkAV is currently offline MarkAV
Messages: 3
Registered: June 2013
Location: Midwest
Junior Member
I've removed my XD from my rack and bought a Crestron MD8x8. Before I retire the XD, I'm going to try another power supply. Is there a pin-out for the Sceptre PS-1250PAL09-4?
Re: RadianceXD issue Sun, 18 February 2018 08:18 Go to previous message
Gordon, Convergent-AV is currently offline Gordon, Convergent-AV
Messages: 1643
Registered: October 2004
Location: UK
Lumagen Expert
Convergent AV
email lumagen and they will give you the pin info. There is a direct replacment available from amazon in uk. Might be one in USA.

https://www.amazon.co.uk/gp/product/B002EKO7BM/ref=oh_aui_de tailpage_o03_s00?ie=UTF8&psc=1


Distributor of Lumagen products in EU
WWW.CONVERGENT-AV.CO.UK
Previous Topic:Radiance 2143 Feedback Question
Next Topic:Radiance xd+ and blinking picture
Goto Forum:
  


Current Time: Mon Sep 24 05:49:03 BST 2018

Total time taken to generate the page: 0.02001 seconds
.:: Contact :: Home ::.

Convergent AV    Light Illusion